QA403 - dbV options - Check Values or Cancel,Gain problem, Program window size

Once i change anything in dbV properties, gets this error. If i delete number and input simpe 4,0 or 6, its possible to go with OK button.
Weird is, even if i press predefined buttons (zero,+6) this error occures.

QA403err

And also looks like external gain has no impact on measured gain, see results in balanced loopback (where i expect to see 0dB gain as it was with QA401 and +6dB output gain preset)

QA403err_gain

QA403err_gain2

And lastly, how do i enable output power measurement ? There is no checkbox or anything how to enable like in SW for QA401.

For the problem with “Check Values or Cancel” my colleague pointed out that it seems there is problem with dot vs comma.

Someone has already commented about the decimal point/dot meaning the same as a comma in certain coubntries/keyboard layouts. Do a search.

My numeric keypad on my standard keyboards doesn’t accept the decimal point either. I have to use the normal full stop when entering a value.

Hi, I think it is enough to select “L RMS pwr Watt” by clicking the mouse button on “Click to add measurements”. Of course you need to set the impedance for the calculation in “dBV option”.

Thanks, thats it. I´ve added measurements with buttons and text “click to add measurement” is covered, so you have to disable measurements to uncover the text and add them with this option.

You can click anywhere around the highlighted measurement tiles to get the option list to add.

To the gap at the left, the gap at the top or to the right, or in a blank space. Just not below.

Good place to click = green
click he no work = red

Thank you John, works a treat !

Another problem, everytime i close program it opens default settings and program window changes its size to some default size !

1 Like

I understand what you mean. But there’s are really simple ways to fix all that.

I wanted to keep my background colour (light) and have the program start up fullscreen. So I had a dig around in the settings files and realised that the default.settings file is rewritten everytime you close the program.

Right click (w10) the shortcut and adjust the properties>shrotcut>run and change to maximised.

I also wanted the background colour to be ‘remembered’ for startup, so I changed the read/write properties of the default.settings file to read only after I had set up exactly the default colours and measurements the way I like them. (the background colour load bug has been reported and will be fixed in the future) edit: I think it’s now fixed

Don’t forget you can save multiple settings at anytime, give them a name and instantly recall them via the load settings function (file>load settings) like this:

image

Much quicker than setting up the analyzer each time. Don’t change anything in lastmodel.settings- that’s just the analyzer model last used and for me, it’s always QA403.

Cheers

John

John, so its same with you ? Program does not remember application window size ? Changing to full screen mode is not solution for me, as i have ultrawide monitor and i dont want to have giant graph 32´ big :smiley:
Old SW for QA401 remembered last size of window so i dont see reason why its not working here :frowning:
What about problem with gain explained earlier ? Do you have similar behavior with your unit ?
@Matt ? Thanks.

1 Like

No it doesn’t seem to remember the last size and window placement.

Maybe ask @matt as I am no expert in the programming side of things- I just poke about in files to see what does what.
I thought this would be the initial positioning, but it appears to be not read or its something else.
image

As for the gain issue, I have no problem with whole or decimal values. I do note that if you type 4,0 it will enter that as 40 If I type 4.0 it enters as 4.0 So there is some difference on some keyboards with the character , (comma) and . fullstop
My decimal point on the numeric keypad won’t work for the gen1 and gen2 direct entry. All minor things in the scheme of things.

Thanks John, I´ve already tried changing Width and Height in config file from 0 to different number, whatever i put in has no impact on window size though.
With problem about calculated gain i mean that explained in post #2 in this topic. For what i can see there is no option to let SW know you are using balanced output, not single ended, i thought this is what is extrernal gain for, but it has no impact.
Iľ wait for @matt to reply.

1 Like

This too has been raised and Matt is aware of it. There was talk/suggestion of a checkbox for “using differential output” or SE which would scale the 6dB difference internally.

For me, I have bench full of legacy test gear and the QA403 is a godsend, but I always do “sanity checks” with levels when differential signalling is involved just to be sure.

Well, so sth what worked correctly in QA401 SW, and is known issue at least from 7/2023 is still not adressed in newer sw release :frowning:

Hi @djrix, let me check on the saving of location and screen size. I can’t remember off hand why that was disabled, but there was a Winforms bug where if you closed the app while it was minimized, it re-launched minimized and couldn’t be restored after that. But I’ll check.

For what i can see there is no option to let SW know you are using balanced output, not single ended

Yes, at the core is the fact that no matter what, user actions (connecting both outputs) need to be correctly conveyed to the SW. And if you fail to do that, the measurement will be wrong. On an analyzer with balanced outputs AND an unbalanced output, the solution is simple: When the balanced outputs are generating 1Vrms the unbalanced output is also generating 1Vrms. So, there’s no confusion ever. The generator settings is correctly regardless of how the user has connected things (unless they connect to just one leg of balanced output).

But with the QA40x, the user is required to ensure the SW settings and HW connections match.

Let me also check on the output gain setting work. I wasn’t super happy where that was heading.

1 Like

Thank you @matt ! What is confusing to me is that both of claimed problems worked just fine with QA401 i´ve been using since buy.

user actions (connecting both outputs) need to be correctly conveyed to the SW. And if you fail to do that, the measurement will be wrong.

Blockquote

Yep, absolutelly, but actuall state is for whom was using old QA401 even more confusing :smiley: With QA401 i knew, when measuring sth with balanced input, i had to set-up output gain to 6dB, with unbalanced re-set it to 0dB.

Hi @djrix, I just looked and it appears that as of release 1.194, the ability to specify output gain has been fully implemented.

As a sanity check, I connected the QA403 in balanced mode (L+ OUT to L+ IN, and L- OUT to L- IN), set the generator to 0 dBV, and then specified 6 dB of output gain:

image

And then the reported level for output and input is correct:

In this mode, the L+ out (referenced to ground) is 0.5Vrms, same for L- out. Combined, of course, that gives 0 dBV. I also confirmed for multitone, FR and noise. The indicator “Output Gain: x dB” will show on the main display to give you a hint you are in this mode. Of course, if you have additional external gain specified, you can enter that too and it will reduce the actual generator level by that amount. But the +6 dB setting is what you want for balanced operation (which is why there is a button).

Can you please confirm you see the same?

PS. The save/restore window location and size will go in for release 1.201.

Thanks, Matt

1 Like

Hi @matt , i´m running v 1.199.
Yes, RMS readout is correct, but the calculated gain is what i´m not happy with :slight_smile:

BTW, discovered another weird behavior - once i click on “Save bitmap as” the app window changes its size - it gets shrunk in width :open_mouth:
And, when changing window size or even just moving opened window on the screen it gets whole gray.