403 generator does not produce chirp anymore

Hi, I have tried to update the software due to crashes I had and after updating the software the SG does not produce chirp signal on the outputs.
All other signals are working fine.
I tryed to revert to other versions, but it still continues.
It does not work with the automated tests ither.
Thanks for the help.

Hi @Deadcap, do you have a message on the screen that says “FFT is too small”?

If the FFT is below a certain size for certain sample rate, then there’s not enough time to do a chirp. And so so signal comes out of the ports. Just increase the FFT size until the message goes away and the chirps should resume.

Thanks, Matt, There is no warning message maybe there should be.
All fixed now.

Hi @Deadcap, good to hear! I just checked and it looks like the “FFT too small” message comes up when it should. If you are at 48Ksps, in FR mode, and the FFT is 16K or smaller, the message should appear. And if 32K or larger, it should not. Let me know if you find some steps to reproduce the message not showing.

Hello Matt. Perhaps I’m not understanding something about “chirp” but the manual refers to pushing the chirp button to enable that function. I don’t seem to have one of those buttons. To get to the chirp settings, I need to use a dropdown menu. Is the printed material just out of date, or is my firmware?


Hi BBTV . I think you are talking about the “FREQ RESPONSE” button in the “GENERETORS” section. By right-clicking on “FREQ RESPONSE” you can access the chirp settings.

Yes, Claudio. Thanks. I did notice that. It’s just that the printed (online) manual seems to indicate that there should also be a CHIRP button in the same area that FREQ RESPONSE appears. It’s not a big deal … just was wondering if the manual is in error or out of date, or my firmware is, or perhaps it’s the firmware between my ears :slight_smile: