Issues with AmpFrequencyResponse automated test

I realize there are other somewhat similar threads, but I feel the need to take a crack at documenting a couple of issues. These may be small potatoes, but I feel like a bug is a bug and should be attended to eventually.

The setup:

  1. Hardware is QA403, with QA40x software version 1.193
  2. Running in loopback with 24" BNC-BNC RG-58 cables
  3. Negative inputs shorted with 50 ohm BNC terminator plugs
  4. Gen1 output level set to 0.0 dBV
  5. Full Scale Input set to 18 dBV
  6. Running a series of three FR traces:
  • FFT 64k @48k sps
  • FFT 128k @96k sps
  • FFT 256k @192k sps

And just for reference, the Chirp version of Amp Frequency Response (AmpFreqRespChirp) behaves as expected. Here are the results with the Chirp version…

So when trying to create a similar chart using the “Stepped” AmpFreqResponse plugin, I run into a couple of problems that do not occur with the Chirp version. They can be worked around, but it’s a pain in the rear to have to remember, and it takes extra time.

Issue 1: The automated test process itself respects the start/stop frequencies in the test settings popup, but the Visualizer does not. Using default settings, the Visualizer always acts to limit the trace to 20-20kHz, and in fact makes it appear that the FR cuts off steeply below 20kHz, even though the test has actually run at higher frequencies. Example…

The workaround is that the Visualizer actually respects the start/stop frequencies set under the “THD” button on the main display panel. By setting the THD stop to a higher limit (which is constrained by the sampling rate), it is possible to get the desired FR traces to appear. Example…

Issue 2: The Visualizer does not respect the “Series Name” text input in the test settings popup, and instead always labels the traces as “0.0 dBV (Left)”. Presumably this is the output signal level value, and I am only plotting the left channel, did not test with plotting Right. The workaround is to use the Traces\Rename Trace menu option in the Visualizer.

Again, not the end of the world, but why don’t they work the same as the “Chirp” version? It’s the little things…

Thanks! - Steve

Hi @GlasgowGrip, duplicated! Thanks very much for this detailed bug report.

1 Like