QA402 Amp THD vs Freq Automated Test Problem?

Am trying to measure the THD vs frequency using the Automated Test function. I am doing it at a “high” power level for this amp (30w/ 8ohms). The problem that I am having is that the routine starts out by putting the attenuator at 0 or 6dB, which overloads the QA402 and it puts a RANGE message on the screen and just hangs up. I have tried starting input levels from -25dBV, with just one 5dB step to -20dBV, or (after adjusting the volume control) from -12dBV to -10dBV with a 2dB step- either way, I am not able to make the measurement. Please advise, thanks
Update- I have the same problem if I set the amp for just 1w/8ohms, but not if I am just testing the preamp.

Hi @VAR, can you share your settings panel before you run?

I also sent you a small video showing what happens. Thanks!

Matt, not that you need it, but here is a screen capture video as well,





(Attachment sc1c.mp4 is missing)

With the latest release, .9961, the swept amp thd versus frequency still does not work with high signal levels, say 1w or >1…

Hi @VAR, are you sure it’s related to power levels? There is an issue where automation doesn’t start after a “File->New” (or app launch) unless you’ve run a cycle manually first. That is, do

  1. File->New
  2. Automated Tests->AMP THD versus Frequency response then click “OK” to start running and it hangs after one iteration as you showed.

Compare that to:

  1. File->New
  2. Press space bar, let a few cycles run, press space bar to stop.
  3. Automated Tests->AMP THD versus Frequency response then click “OK” and it runs to completion.

Can you see if you observe similar?


No difference when using either method- stops right away. As I said, it sets the attenuator to 6dB right off the bat and is overloaded as I am measuring at least 1w. I can do video screen capture if that will help?

I find I need to shut off the auto range and select an attenuation setting that won’t clip, then it works.

My two cents

I have been having the same experience. No combination of settings seem to allow the test to finish, it just hangs or presents a blank graph. Using 0.9661

Thanks for the input- when I unchecked the “Autoset Input Range” box I was able to get the measurement! I can sleep well tonight… :upside_down_face:

Hi @Botte, thanks for that observation–that was the issue. Fixed in release 0.9962 for the 3 plug-ins that use the autoranging (release located here)

FYI, it still overload errors out with the PWR THD vs Power test.

I had the input level adder set to 0 because I’m not using a pad. I changed the setting to 18dB like the default and the auto set range works.

Hi @Botte, I think this makes sense because if you specify the adder of 0 dB, you are telling the test to set the input level 0 dB above the input level (eg edge overflow). And it tries to get as close as it can-so, if your input level is 1 dBV, and you have specified 0 dBV, it will opt for 0 dBV input range which will result in a clip.

Probably it makes sense to set the lower bound to 6 dB rather than 0, which means you will always pick the attenuator just above your input level. This will be changed for next release. But for now, just assume the values of 0…6 dB don’t make much sense. Really, I think you want it around 18 for best THD.