Q401 THD+N test plug in / graph tool issue

Hi Matt,

I was measuring a DUT I’m very familiar with on my QA401, and started getting some unusual errors using the PwrThdVersusPower.dll testplugin. On the main screen the THD and THD+N values vs. different power levels were all as expected based on familiarity (dropping to about -95 THDN). But the plot and trace export after running the testplugin kept outputting a plot that was far too low - below 110 db THDN for example. Exporting the trace to a csv also showed incorrect values that did not match the measurements on the main screen while the test was executing.

The dll also appears to be ignoring settings / has stuck settings. For example, no matter how I change early abort settings the test ignores the early abort (I’ve used it successfully hundreds of times). The settings UI for this testplugin also seems to not remember changes I make - for example, if I set -60 for the early abort it reverts to -40 (my usual setting) next time I select that plugin. It also ignores whether I toggle to measure THD only vs THD+N - the same wrong values are plotted on the graph tool graph.

I’ve tried resetting the application to defaults from the file menu, unplugging and repowering the QA401, same issue. I’ve tried un-installing the software and re-installing (version 1.920) and no change. After rolling back to 1.907 things started behaving again. Un-installed 1.907, re-installed 1.920, and the issues returned. Another testplugin I use (AmpThdVersusFrequency) runs and graphs properly.

Can you help me figure out why using PowerThdVersusPower isn’t working correctly for me? I’m using windows 10 and grabbed 1.920 from the QA401 section of Github (unless I should be using QA40x?)

EDIT: The graphtool won’t plot THD with 1.920. I’ve attached two screenshots of the familiar (expected) DUT performance with what I’m getting with 1.920.


With 1.920:

Hi @chrichap, could you please try release 1.924 (link below) and see if that fixes these issues you are seeing?

I just tried (using 1.924) to graph THD and THD+N and it did so, and it seems to be remembering the settings.

Note that the “Enable Early Abort” must have TWO things be true in order to trigger. First, you must be above the “Abort Minimum Power Level (Watts)” that you have specified. Second, you must have a THD that is worse than the “Abort Maximum THD (dB)” you have specified. The minimum power level requirement is so that you don’t abort the test when you are at the far left side of the curve and THD is poor because signal levels are so low.

If 1.924 doesn’t change things for you, can you please share your settings for the test? Thanks!

Hi Matt, I tried 1.924 and the same issue persists.

The latest software that seems to work correctly for me (now) is 1.909. Anything newer than that seems to behave incorrectly.

I forgot to add to my initial post that prior to yesterday I had been using 1.920 since it was posted last December without issue (including early abort and other common settings for the PwrThdVersusPower testplugin).

My understanding is the software updates the firmware on the QA401 automatically. Could a firmware update have gone wrong?

Hi @chrichap, in the QA401 install directory (usually at c:\program files (x86)\QuantAsylum\QA401) has a file in there called QA401.bit. When you install a different version of software, that bit file will be updated. But if for some reason it’s not updated, then, yes, it could get out of sync. If you think they got out of sync, you could always delete the bit file, and then install the new version and verify there’s a bit file written.

Could you please share the steps to reproduce the precise problem you are seeing in the latest version?