QA40x Software Release 1.13

Release 1.13 for the Q402 has been posted HERE

I like the new layout but there appears to be a bug with the GEN 1 not updating the freq and amplitude:

It appears to update the EXP Chirp fine. If I select GEN2 then GEN 1 can be updated, but reverts back to another value if you turn GEN2 off…?

Now this S/W is called QA40x is the intent it also works with the QA401 H/W?

I just get the message ‘connect h/w’ bottom left when I tried it so assume not.

Simon.

Hi @SABristol, thanks very much for reporting, I should have caught that. It is fixed in 1.131 located HERE

Now this S/W is called QA40x is the intent it also works with the QA401 H/W?

It’s starting too. It’s not too exciting yet as all you can do is exercise the attenuator on the QA401. But, the way it works is as follows:

  1. Close the QA40x app
  2. Start the QA401 app
  3. Plug in the QA401 hardware. Wait for the configuration to complete.
  4. Close the QA401 app
  5. Start the QA40x with the -qa401 flag

The easiest way to do step 5 is to navigate to your QA40x.exe directory in File Explorer, then enter CMD in the navigation bar of file explorer. That will open a command window in that directory, and you can type

qa40x -qa401

And you’ll see a message box that indicates a model change:

image

The application will then try to re-flash the QA401. Allow it to. Nothing will actually happen. But then you should see the QA40x software come up with just two input ranges. Clicking the two input ranges should toggle the QA401 relays.

And you’ll see junk for the firmware version and USB voltage, etc.

The above are OK for now. It’s just to get some of the QA401 functionality merged into the main QA40x branch so that the real work can begin.

Eventually, the app will automatically look for all models automatically.

1 Like

I just installed 1.13 and every time I try to run an automated task, it throws an exception. I’ve tried rebooting, changing settings, clearing all settings and starting with a new one, but can’t get automated tests to run.

PS - just tried 1 .131 and this problem still exists.

PPS - I’m kind of neutral about the new color scheme, but I’m still waiting for the ‘dBr 0dB to track peak’ feature. :smiley:

Same here on automated tasks. I get this.

Also this happened on earlier version but if I hit new setting, I often get,

“Eventually, the app will automatically look for all models automatically.” The QA400 as well? That would be quite interesting.

Hi Matt.

That worked :slight_smile:
The 6dBV and 20dBV buttons toggle the relays fine. Assume nothing else works until your work to migrate is done.

Initial thoughts:

  • Like the axis preset buttons. Will QA401 actually get ±1dB as currently ±5dB is the smallest range we get on the current SW?
  • I’m not using a particularly small monitor (1920x1080) yet still have to scroll the control panel to find the run button. Can we have a more efficient hmi by using smaller font / buttons? On the QA401 S/W the whole of the control pane easily fits in the 1080 screen height.
  • Some on the forum have done work on more accurate RIAA user weighting files which could be packaged by default. Dropbox - RIAA User Weightings - Simplify your life
  • Off topic but noting the QA402 has an i2s interface, are QA planning on selling digital I/O box at some stage or are you recommending diy?

Thanks.

Simon.

For what it is worth, below is a link to my RIAA “hires” file, which you may add to your dropbox if you’d like. I agree with you about the the whole control panel screen being able to fit w/out scrolling (my monitor is 27" 1920x1080).

Thank’s, I added it as ‘RIAA Playback Super High Res’. What’s SLC?

Anyone else having problems with 1.13.1 just throwing errirs and wanting to quit the app? If I am doing a measurement with Gen1 into a passive notch then back into the input, 0db atten, and then try to switch in and out of weighting filters, it keeps throwing errors. Also if am in the middle of a measurement it randomly throws an error if I try to switch FFT levels.

My initials- my “moniker” is VAR :slightly_smiling_face:

1 Like

The last version where I can get automated tests to work is v1.120

The plug-ins should be working again in 1.132 HERE

dBr tracking is in the queue, but not sure when it would go in yet.

@SABristol, thanks for the report of the QA401 toggling relays. Yes, most everything in the QA40x will work for the QA401. No plans currently on an IO box for I2S. The initial task is to enabled those building digital input amps to test. 100% agree on fitting into 1080 height. The 1.132 release today took out the logo as a first start. I woke up and read @dave 's comment and it made perfect sense. It’s a good goal. The issue on button sizes and contrast is for those that are stuck at a touch screen all day. Maybe they can shrink more.

This is a minor one with v 1.132 - Neither of the Y axis preset buttons are not illuminated, however clicking on them causes the expected change in Y axis scale.

Also almost all the other buttons have a weird behavior where the previously selected button flashes instead of the newly selected one when that new button is selected.

Hi @Rammis, a button will flash for one of two reasons:

  1. It’s a one-shot button. That is, it does it’s job and then is done (eg reset averaging)
  2. It’s a member of a group where only one button can be pressed at a time (eg full scale input)

So, if you are at 0 dBV and you press 24 dBV button, the 0 dBV will flash for 250 mS as the 12 dBV button is engaging the relay. The aim here is convey a mutually exclusive operation (eg White Noise and Freq Response can’t be on at the same time).

And since the Y preset buttons are one-shot (they set the axis once and they don’t hold the axis), they will also blink to convey one-shot behavior.