Version 1.202 not updating firmware

Am not sure what I am doing incorrect, but I installed the latest release (1.202) and it is wanted me to update the firmware, but continues to give me error codes and will not run. Here are the screen captures of the messages…
This is the 1st message and I click YES

Then I get this message:

followed by this message after unplugging the QA403:

I went back to version 1.198, which is working fine…

Did you press OK before unplugging the QA403 on the second screen? The message, bottom left corner in green was saying update in progress.

I haven’t done my update yet.

I am pretty sure I did as I tried it several times with ultimately the same result. At least the version I had been using works just fine.

1 Like

I can confirm 1.199 had been perfectly fine for me.

I hope you can get it sorted- maybe ask Matt?

Hi @Var, I just downgraded to 1.137 and upgrade to 1.202 several times to check without problem.

One difference between your screen and mine is the status bar message when it says “Flash Complete” Note on mine it shows “Finished. Replug Hardware” in the status bar. Yours shows the firmware version.

When yours is updating the flash, do you see the messages in the status bar about “block x of y”???

Also, when you replug the QA403, note the message about waiting one second to plug it back in. Can you unplug when instructed and then wait 5 or 10 seconds to plug it back (after the update) in and see if that changes anything?

Thanks for getting back with me. I just made a video to show exactly what is happening…

Are you running the program as administrator?

I have not tried that, but I have not needed to ever “Run as administrator” since I have been using my QA40x gear…

Hi @Var, OK, this shows the issue clearly. It never gets to the point where it’s iterating blocks (for example, “block 938 of 52293” and then a message says it wasn’t in IPS mode. IPS mode is the bootloader mode. So, for some reason, your unit isn’t entering bootloader mode when going to 1.202. And so, when you go back to 1.198, it’s not really having to go back, because the firmware is what is needed for 1.198.

I wonder if you tried to go to something earlier if it would work?

I installed 1.180 and then ran it and it was ok- still shows firmer vers. 58, Then installed 1.202 and it gave me the same errors. I have not tried it with my QA402x…

Is there an issue with jumping straight from firmware 58 to the firmware used in 1.202?

Do we need to do 1.200 (firmware 60) first?

1.198 was the latest version that I have been running- never installed and tried running 1.200 but it is easy enough to try…

1 Like

@restorer-john @matt - I installed 1.200 and it went through the same routine of errors as with 1.202 :thinking:

Hi @Var, do you have another machine you might be able to try? I can’t think why it would make a difference, but…

Yes, I will hook it up to my other PC, install 1.200 first, and report back. Well, that solved the problem. I connected the QA402 first and it updated to firmware 60, then hooked up the QA403 and it updated to 60, then installed 1.202 and both were ok with that and now the QA403 is working with the “problem” PC with 1.202. Both are running windows 10…Thanks for the help and I feel a bit dumb as I should have tried that to start with…

That’s great. :slight_smile: I’ve been watching this as I have a few machines and sometimes move the QA403 between them, but didn’t want to get into a software/firmware mixup myself when I do the latest app install.

I typically update both my desktops and one laptop at the same time, but the Qa403 is almost always hooked up to my “work station” PC, which is the one that would not update for some reason, strange stuff indeed.

Hello, i did right now the Update on my QA403 from Firmware 58 to 60 (Windows 10 Pro, Software from 1.197 to 1.201) without any Glitches or Errormessages :wink:


1 Like