Problem generating frequency response masks

I’ve tried to follow the instructions from and I’ve run into an issue: when loading the generated mask, it looks like a mess (see attached captures) although it looks fine in the graphtool.

I’ve tried this on versions 1.920 and 1.909 and it happens on both.

This is how it looks when generating the mask:

Hi @ruben_ta, thanks for sharing the mask file–that clearly shows the problem. The contents of the mask file are showing decimal point in your local culture. So, 100,3 instead of 100.3. The software should have written these values in a “culture invariant” format which means 100.3 regardless of culture.

I have made the fix in 1.924 but I don’t have a way to easily test on this machine. Can you please run 1.924 and see if it fixes your issue?

Thanks very much for reporting this.

Sorry for the late answer!

I’ve tried the new version and while the “crazy mask” problem is gone, there’s still bad news:

First, when running the AmpFreqResponseChirp plugin with the following settings:

The resulting line is not on 0 dBV as it should (and as it shows on the main program).

This is with both outputs of the left channel hooked up to both inputs and external input gain set to 6 dB.

And also, the mask is not showing!

Hi @ruben_ta, thanks for verifying the new build. the issue seems to be related to the attenuator setting. Can you verify this makes sense for you IF the Max Input Level is set to +6 dBV?

Yep. turning the attenuator off makes all the lines make sense and the PASS/FAIL value displayed when using a mask works. There’s still the problem of the green lines of the mask not showing on the main program, though.

Hi @ruben_ta, OK thanks, will check the atten.

Did you specify and load the mask?

Yes. In fact, if I check “Display Pass/Fail”, the FAIL / PASS messages shows and seems to work fine. It’s just the mask lines that are not showing.

Hi @ruben_ta,

Can you try this process to see if we can get to the same place:

  1. File->Reset Startup Defaults
  2. +6 dB input level
  3. L+ OUT to L+ IN, short L- IN
  4. Run AmpFreqResponseChirp 3X with the following option (and saving all results to same plot):


Then you get a graph with 3 traces:

And then do Math->Add or Edit with the following traces:


And now we can limits added to graph:

Then do Traces->Export Mask in the graph tool. Save it as Mask17

Then go to FR context menu, set amplitude to 0 and select the mask just created:

Then make sure you are zoomed enough to see the mask in the main display:

If I go back into the context menu, and set the level to -1 dBV, and opt to show pass/fail I get this:

And on the main display, if I do another sweep at -1 dBV (entered above) this time it shows fail because it’s outside of the mask:

Please let me know if you can replicate! Thanks

Hi @matt! Just did those tests.

Things seem to work fine while generating the mask (although there are differences when the attenuator is on/off). But when I load the mask and set a similar zoom level to yours just… nothing:

(see next post)

Let me know if there are more things I can test on my end, and thank you for your time!

After loading the mask:

OK, thanks, that’s a good clue. I think the issue must be on loading the mask file given your culture settings. Can you please send the mask file to the mail address below?