QA 450 Firmware Update

Hi, I just opened the QA450 software and got a message box telling me to update the firmware. So I clicked ok and a dialog opened up titled “Enter Flash File”. I’ve not been able to find a firmware update on this site so I just clicked on the file QA450.boot listed in the dialog. Which threw the following error “An exception occured during reflash: Index was outside the bounds of the array.”
So I’ve downloaded version 1.22 of the software and it’s still the same. The QA450 is listed as ‘USB Input Device’ in windows and the software no longer recognises it.
Any advice on getting it working again?

Hi @SimonA, what is the VID and PID listed in Device Manager (right click on device, select “details” and set property to “Hardware Ids” and you should see the VID:PID reported.

Thanks, Matt

Hi Matt, it’s showing up as a ‘Generic USB Hub’ with the following


I don’t think that’s it. The VID should be 0x16C0 if it’s programmed and 0x2047 if it’s not. Usually it will show up on Human Interface Devices as a “HID-compliant vendor-defined device.”

If you replaced the MSP430 as part of your rebuild then the flashing will be a different process. But first we need to make sure that Win10 can see the device.

Okay, I think I’ve found it here’s what’s listed under Hardware Ids:

So it looks as though it’s not programmed. BTW I didn’t decide to rebuild the device, the software told me to and instigated the process… I just hit an okay button twice.

Hi @SimonA, that make sense.

OK, so the VID of 0x2047 means the device is effectively “unflashed” and needs a special procedure.

In the QA450 app, click on the app title bar to ensure the app has focus. Then type the keys ‘qa450’ (no quote). You should hear a beep–that indicates you are in factory mode and a new menu item (Factory Flash) should appear.


Re-plug the QA450 and wait for Windows to do it’s bing-bong sound indicating it has enumerated the device. And then from the QA450 app selection Tools->Factory Flash and select the QA450.boot file that is offered.

You should hear Win10 play a few more connect/reconnect sounds and on the lower left of the app you should see a message as blocks are updated. Finally, you should see a message that the flash update was complete.

Then, close and re-start the QA450 app and re-plug in the QA450 hardware and I think you’ll be back in business.

Please update after trying…

Yup, that did the trick… worked out exactly as described. Thanks Matt.