QA402 software questions

Hi Matt,

I’m liking your updates.

I’m having issues with the graphing from the plugins. Sometimes they just pop up, sometimes they do not. Sometimes it asks if I want to add to an existing graph and it wil pop up. Other times nothing.

I was running the plug-in, changing parameters then running it again over and over. So maybe it’s just me…


I just just installed 991 software. Two problems I keep having are 1) display in watts is toggled but never appears 2) using 192K should allow display of a few 20KHZ harmonics but this setting does not “stick” and\or the graph will not scale correctly. Getting better all the time otherwise.


Hi @Botte and @kamco, release 0.992 posted today and there is now a new measurement you can add (filter by ‘watts’ to find it) and it should respect the impedance setting you have specified in the dBV context menu. The math is the peak RMS squared divided by the impedance. Note that the RMS and the peak Vrms aren’t necessarily the same. The RMS is over your specified measurement bandwidth, the Vrms is the highest peak seen in the measurement (and windowing can play a role there if you aren’t using the generator with rounding enabled).

The problem is noted on the graphing and no it’s not you. There are two things happening. The first is the sometimes the new window will pop-under the application and so you have to dig to find it. The second thing is that there can be phantom graphs that the program thinks are there but they aren’t (because you closed them). And so, when you add the measurement you just made, it will be asking if you want to add to the phantom graph (note the graphs all have a unique 3 digit number in the title bar). So, if you want to add a measurement to a graph then make sure the graph it is asking you to add shares the same number as the graph you want to be added to.

The impedance plug-in for making automated amp output z measurements on the QA451 goes in late next week and I’ll make sure the graph issues get address.

Release 0.992 is here. Graph titles are now multi-line too.

I’ll check the 192K and harmonics.

Hi @Kamco, I just checked on 0.992 (0.991 should be the same) and it seems to work. Try this to verify:

  1. L+ OUT to L+ IN. Short L-IN
  2. File->New
  3. Set Gen2 to 20 kHz and -20. Start acquisition and verify you can see it. Then stop acquisition
  4. Switch to 192k
  5. Press Run
  6. Right click on X Log and set end freq to 100k
  7. Set Gen2 to 90k.

You should see a tone out at 90k:

This worked fine and I can see the higher harmonics reliably. I don’t know what I was doing before - clearly a case of user error. The issue of the 192k setting not “sticking” still persists, I can save a settings file with 192k selected, but loading this saved file in a later session will show 48k selected. Maybe this is by design?


Yes, this is by design. There are some settings that don’t persist across sessions to avoid confusion. For example, if you close the app with Idle enabled, it will be disabled when you re-start the app. You need to re-enable it.