QA402 “Wear” Maybe?

@matt I haven’t used my QA402 since I got the QA403 in the early days. I finally went back and just wanted to check on the performance compared to spec.
The first pic is the noise floor. Seems to be fine.
Then the setup per spec with atten at 12db then at 18db.
I’m sure the unit met spec when I first got it. This has been used in a non commercial environment so not many hours but it seems to have fallen below spec. The loopback is with a 1ft cable and I tried 4 different ones. I also tried all permutations of L and R +/- both on outputs and inputs. Both Sig Gens were used and this is all on battery powered laptop with no other devices connected to the laptop. The 3 unused inputs were all shorted with 75ohms. Any ideas?

Hi @Moto. I’ll ask you a silly question. Have you thought about replacing (in the same place, with the same cables and at the same time) the QA402 with the QA403 configured the same as the QA402 when you get these results and see what you get? What makes me suspicious is the combination of harmonics from about 10 kHz and up. Try turning off the generator (but leave it plugged in) to see what happens.

I would certainly try that but the QA493 is in a different city now.

I did the same measurement with my QA402. My device shows about 3dB worse results than Moto’s unit. I don’t remember the results when the device was new but I would be surprised if wear will cause such degradation of performance. I observe the same noise at higher frequencies.
For the measurement, the laptop was running from battery, delivering about 4.7V to the QA402. I still need to test if the performance will be better if I use a USB hub with stronger power supply.

@Claudio here is the measurement with the cable connected from the generator to the input without any signal from the generator

Ooops. Wrong photo but I can’t figure out how to delete it. Here’s the correct one.

Well further edit. I had User weighting on for a notch prior to doing this measurement but as you can see from the pic, I turned it off. However when I just did a Settings->New and retested this is what I got which now makes sense. I realized I had a gain setting on which caused the better results.

Interestingly I get a much better noise floor when connecting a + output to a - input.

Hi @Moto. I had suggested this test to see if by chance the noise evidenced by the harmonics from 10Khz onward was of the external radiated type captured by the cable. Evidently, however, it seems instead to be produced by the generator itself. Unless this test was done at a different location than the previous one where the noise harmonics were seen. In other words, one would have to test first with the generator on, then with the generator off but in the same place at the same time.

@matt I tried duplicating the graph from page 10 of the spec document but am still falling short of your numbers. Would you regard this as out of spec. Also interesting that my right and left channels are different at lower generator output levels but mostly identical after -10db, the opposite of your results. This was using 128k fft and 12db range adder.

Hi @Moto, can you share a THDN loopback at -10 dBV with the input set to 0 dBV full scale?


I have similar results

@matt I uploaded the measurement you asked for.

@matt anything else I should do?

Hi @Moto, your unit is working as expected. In the link below, see the discussion on whether the DAC is being set to optimize for THD or optimize for THD+N. They are different settings and these aren’t adjustable by the user, although they might be at some point down the road. In short, to optimize for THDN loopback, you’d want to have the software adjust the relays and run the DAC very close to full-scale output… And if you optimize for THD, you want to have the software adjust the relays and run the DAC about 15-20 dB away from full scale.

So, if you specify 0 dBV full scale output, and you wanted to optimize for THD, you’d set the DAC attenuators to 0 dB (18 dBV full scale output) and then send a -18 dBFS output stream to the DAC. If you wanted to opimtize for THDN, you’d set the full scale output to 8 dBV, and send a -8 dBFS output stream to the DAC. This assumes you have full manual control, which isn’t an actual option.

@matt I’m sorry. I must have not made myself clear. I was aware of the info you included in the last post. My real concern is that I can’t seem to duplicate your specs for the device or the the results you show graphically in the document with the specs in it.

Hi @Moto, it’s because the loopback mode in current software is set to “optimize for THD” rather than “optimize for THDN” and the THDN loopback shown in the product sheet is using “optimize for THDN”. Even though it’s a software switch, it’s not been surfaced yet in the UI so that users can control it because I think it would tend to confuse people.

That’s interesting but I get it. I also can’t match your thd and thd+n at 1kHz in the spec though and have tried many combinations of attenuation and signal level. Do you get -110 thd and -98 thd+n @-2dbv at different attenuation levels ?

Hi @Moto, for the QA402 on my desk, I get the following at -10 dBV out, single-ended loopback, and +12 dBV input:

At -2 dBV out with single-ended loopback and +18 dBV input I get:

Replicating your -10 dBV output (single ended) and 0 dBV full scale I get:

The harmonic levels are very close between our two units at this point.

Thx @matt. I can replicate those so if it ‘s good for you, it’s good for me!

I have been following this post closely as it was very interesting. I’d love to see a “optimize for THD” and “optimize for THDN” choice.