SOLVED: QA403 software runs on Linux but can't see device (device and software work on Windows)

Hi all

The device runs on Windows, so it’s not a hardware issue. The software also runs on Linux, but it can’t find the device, that’s what my problem is.

I followed the steps here and the software runs OK (displays the default screen, but has an orange “Connect the QA403” label in the lower left), but it can’t find the QA403, even though Linux can and udev created a device node for it.

One of the issues is certainly that the .wine/dosdevices folder does not have a proper symlink to a device in /dev. I couldn’t find a way to have them created automatically, so I created one manually, with the name libusb0-0001 (because I saw in strace that the software was trying to access these) and had it point to /dev/bus/usb/<bus>/<device>, where <bus> and <device> came from lsusb. Then I could see that the software did open the device, and did so successfully (so no permission issues). It then issued a TCGETS ioctl (WTF?), which failed with EPERM (WTF?, normally you get ENOTTY) and then closed the device again. The QA403 devices are NOT supposed to be /dev/ttyUSBxxx, right?

Does anyone know what could be going on?

Information about my system, I’m happy to provide more details if needed:

Kernel 6.1.0 on stock Debian, Wine 9.1, Mono 8.something.

Cheers and thanks in advance,


EDITED TO ADD (2024-01-31): I started the QA40x executable with mono instead of wine and now it works. No idea why, but it does.

Congratulations on getting your QA403 running on Linux! I tried doing the same on macOS a few months ago and failed, I’m sure it’s possible but it just would have taken a bit longer than I wanted to spend on it.

In the end, did you have any modifications of additions to the documentation here QA402 Software on Linux and Mac ?

No, except perhaps to add, in bold and italics, that you should run the software with mono, not wine, just in case you get another thicko like me. Once I have my equipment (still waiting for BNC-to-RCA adapters and the shorting blocks), I’ll see if I get the memory leak issue that is described elsewhere in the docs.

Maybe it’s a good idea to consolidate everything into one document?

Thanks for following up and cheers!


Sten, would you be able to run through the steps you took to get the QA-40x working on Linux? I want to see if I can run the QA unit on a Linux mint all in one 24" PC on my bench.

I’ve installed wine and mono, but seem to be getting nowhere.

Cheers, John

Hi John

Sure, I’ll be willing to help!

But since I’ve been using stock Debian and you are using mint, it’s likely that there is some significant difference along the way. I think it’s easier if you write what you have been trying to get the thing to run. For example, can mint see the device with lsusb? Have you been able to run the installer? What error messages, if any, are you getting when you run the software with mono?