Software Release 1.178

Hi @Matt. I have downloaded and installed version 1.178 of the software. The software starts regularly and works fine. However, I have noticed that when I try to close it, version 1.178 does not close, it crashes and the operating system (windows 10) tells me that “QA4x no response”. This always happens when I do acquisitions with the new version (1.178), whereas it closes regularly if I start the programme but do not do acquisitions. I am currently back to version 1.176, which does not have this problem. Thank you

1 Like

Hi. Here is a screenshot from Windows 10 about the problem

Hi Matt,
exactly the same happens to me too. Windows 10, on 2 different computers.


Hi. I too have tried on 2 different laptops, Lenovo i3 and Samsung i5, the problem shows up identical on both computers. Thanks

Hi @Claudio, I think this was a byproduct of the USB changes to help with missed measurements at high sample rates. Looking at this more, if you stop measurements before closing it works, but if you close while it’s making measurements it will often hang.

Release 1.180 is now up that made changes in closing. Can you see if this fixes the problem for you?


Hi @Matt. I just downloaded version 1.180 on the two laptops that were crashing with version 1.178 on program exit. I did 5 acquisitions on the Lenovo i3 and 5 acquisitions on the Saamsung i5 (Win10) and after each acquisition I closed the program. Everything ran smoothly and the program always closed without creating any problems. It seems that the problem is solved. I will continue testing to see if the problem recurs.
Thank you!
P.S. I always hope that in a future release it will be possible to optionally include the date and time in the various printouts :smile:

Hi @Claudio, good to know, thanks!

I agree on date/time. It will come!

Hi@Matt. To me this is great good news. Thank you!!!

Matt, ver.1.180 working fine here too. :+1: