Test Plugins crash


I have a problem with most of the plugins, i.e. all that measure any kind of distortion (THD, IMD).
They throw exception at each step of execution. It’s possible to dismiss the exception, but there is no curve at the resulting graph.
The exception is not the same at each of the machines I installed.
Windows 7:
“QA Remoting Exception: RemotingSetGenerator() exception: Exception of type ‘System.ComponentModel.InvalidEnumArgumentException’ was thrown.”
Windows 10 has completely different exception message.
On couple other machines (also Win7 and Win10) there are no exceptions, plugins work fine.
I tried several DotNet Frameworks versions at Win7, from 4.5 to 4.8, the same result.
BTW, although QA Analyzer requests DotNet4.0.30319, it doesn’t work with that version (“Serious Error occurred”).

Hi @zoran4afc, what that exception seems to suggesting is that the plugin DLL is unhappy with the number of arguments the host application (QAAnalyzer.exe) is offering. When the DLL is compiled, it’s compiled against a specific version of QAAnalyzer. Of course, over time, QAAnalyzer APIs will change as more functionality is added.

So, my guess is that there are old DLLs in the Scripts directory. Could you please try the following:

  1. Close the QA401 app
  2. Go into the C:\Program Files (x86)\QuantAsylum\QA401\Scripts directory and delete all the files.
  3. Re-install the QA401 application. Please install release 1.907 located HERE. Version 1.908 is newer, but it’s not signed as we’re waiting for DigiCert to migrate their code signing certificates.

See if that fixed your issue on the machines that are giving problems.

The QA 401 app requires the target framework 4.5.2. But I think that the OS does a good job of solving this for you on Win10. Starting at DotNet 4.5, you don’t need to worry too much about having the precise DotNet version installed because the compatibility is solid. Looking on a fresh install of Win10 with updates, just 4.8 is installed. But the QA401 app runs fine–you don’t need to install 4.5.2

Hi matt,
thank you for fast response.
Deleting C:\Program Files (x86)\QuantAsylum\QA401\Scripts directory didn’t help, but uninstalling QA Analyzer, then deleting ‘My Documents\QuantAsylum’ actually did. The plugins work after the new installation of QA Analyzer.

I installed QA Analyser 1.906, because versions 1.907 and 1.908 are failing to control the output level of external DAC when using “Mirror QA Output to PC” option.
I already reported that problem to support email.
I will now create another topic for that issue.