QA401 GUI and Desktop Scaling

Hi. The latest release and pre-release versions of the QA401 GUI both run into issues on a Microsoft Surface Pro 6. The screen specs are:

Screen: 12.3” 
Resolution: 2736 x 1824 (267 PPI)
Aspect ratio: 3:2 

Microsoft default is to run 200% screen scaling for text legibility on the small screen. The QA401 GUI launches properly scaled but resets to the native screen resolution with 100% scaling when a random control button is clicked. Menu text become ~1mm high. It doesn’t appear confined to a particular button and occurs erratically. Sometimes the GUI works fine for a bit then re-scales on the next click.
When this happens the GUI changes from full to partial screen. Clicking the maximize button makes the GUI window smaller. Clicking a second time maximizes the window without scaling. The Surface OS is fully updated. Using a display setting of 1920x1200 with 100% scaling may work properly, it hasn’t been used enough to be certain.
Apologies for the amount of info here. Any suggestions on locking the GUI resolution? Thanks.

Hi @rdf, when you say " Using a display setting of 1920x1200 with 100% scaling may work properly, it hasn’t been used enough to be certain" is this a global settings you are making the display settings or are you setting the DPI for the app in the right click on app, properties, compatibility, set high dpi options?


Hi Matt. Thanks for the suggestion. It’s the global OS display setting under Windows control panel.
I can’t seem to bring up the right-click context menu you advise. Other than on dotted buttons or marker options in the graph area, right-clicking or ctrl-right-clicking anywhere else on the interface doesn’t raise a context menu.

Hi @rdf, there’s also a per-application setting. I have no idea if this will do anything or not, but it does change the scaling on my 96 dpi machine…first find the exe in the install location:


And then, right click on the EXE and bring up properties, and then compatibility:

And inside there you have a few options for changing. I think if you set the override to “application” then it might not apply the global settings and it will let the app do everything. And since the app does nothing explicit to change DPI, maybe it will just work???

1 Like

Hi Matt. The “System (Enhanced)” option under High DPI scaling appears to have done the trick. Looks normal and can’t find a way to break the GUI now, thanks again for the guidance!