QA402 display trouble

When I click to “add measurement”, I can’t find “OK”, “Cancel”
button of the add measurement pop-up window.
(QA402 version 0.998)

My WNDOWS 10 PRO is the Korean Language version(not
English version) , and I’m worry if it was for the difference
of the display method of the Universal Coded Character Set.

Not sure if this will solve your problem, but check this post:

Thank you for your kind email.

I followed that post, and fixed some of the troubles.

I’ll post the fixed results.



I checked the properties of QA402.exe, then
Window10’s troubleshooter suggested “Windows 8 K” mode.
I accepted the mode and saved.
The results : not complete, but appeared the buttons of “OK” and “Cancel” as following image.

Other options in the properties were not effective.
The fixed results are not complete, and I’ll wait if there were another trouble shootings.

Hi @sohon23m, there is a change coming in version 0.999 (hopefully out today) that will limit the height of the dialog box in question to 640 pixels. Windows 10 is doing some scaling for some reason even though there is plenty of screen real estate. This happens with a lot of apps, including microsoft’s native Win10 apps. But there doesn’t seem to a single fix other than changing with scaling.

Once 0.999 release, we can see if it works around the issue on your machine with the shorter dlg.

Hi @sohon23m

Release 0.999 is located here. Please report if the shorter “Add Measurement” dialog can be displayed.

Hi, Matt
I’ve just installed Release 0.999, but unfortunately can not
see the “OK” and “Cancel” buttons of “add measurements” pop-up window
(same as Release 0.998)

In the “Windows 8” mode(changed at the Properties of qa40x.exe),
parts of the buttons can see, and can click, as the following captured image.

While the new menu “CURSORS” of the control panel, I can’t read
the buttons’ name.

Hi @sohon23m, I think your issue will take several tries to fix because it cannot be replicated on a computer with western font.

Release 0.9992 is located HERE and it uses a different approach for the dialog. The previous solution reduced the Height of the dialog, which didn’t change anything on your machine.

This dialog is unique because the controls are autocreated at run-time. The 0.9992 release tells Windows to performing scaling after the dialog is constructed, rather than than before. I do not know if this will fix it, but we’ll need to try in incremental steps.

I did check the dialog under Mono, and it renders correctly there.

Please report your findings with 0.9992 when time permits. Thanks!

Hi Matt,
I’m happy to report that most of this window size
issues are fixed.

I’ve installed QA40x_v0.9991 (I couldn’t find out
QA402_v0.9992.exe) and the screen shot is :

Today, I’ll try to install QA40x_v0.9991 or 0.9992
on my linux(Ubuntu) via MONO.


Today, I thought out suddenly that I have a
retired old hard disk, so I installed the Windows 10
English Edition to that disk temporarily.

In English Windows 10, the “Add measurements”
pop-up windows are displayed perfectlly,
both in your previous 0.998 and new 0.9991 versions of


I installed Linux Ubuntu Desktop 20.04 LTS,
selecting OS language -first in English,
next in Korean Hangul.

When I’ve finished install mono and
qa40x.exe,inspite of some errors,
perfect both in English and in Korean Hangul.

The trouble occures only Windows 10 Korean
language Edition.

screen shot : Ubuntu-Korean Hangul
QA402 version 0.998

Hi @sohon23m, what is strange is how the buttons are “compressed” in height. Notice that the button height is much less than the adjacent text entry box height. Normally, they are almost the same height.


I don’t think we covered before, but can you please explain again your display resolution and the physical diagonal measurement OR your system PPI?

Hi Matt,
I can’t figure out this probem, because I don’t know about coding or developing the programs.

I only guess vaguely that Microsoft appies the different
rules on window size to Windows10 Korean Edition.

  1. My monitor’s sepecification

  2. Supported display resolutions of Win_KN

    (I tested many size of resolutions, but the results
    were not changed.)

  3. The other test
    I compared the size of the pop-up window
    displayed by Win10_EN and Win10_KN.

Befor the test, I clicked the top of thet pop-up
window to enlarge to full-screen size(Win10_KN).
to see the hidden (or compressed) area.
The following is the full screen of pop-up windows
of Win_KN.

Then I compared the size of the pop-up window
of the Win_EN to the Win_KN.

It is large in width, small in height at Win_KR,
compared to Win_EN.

I don’t know if these tests would be a hint for your
solution, but if you need more tests, I’m willing to
help you.

Two more tests for pop-up windows of “Add Measurement”

  1. New install : Windows11 preview build 22454.1000 Korean Hangul edition
    –>Results : same as Windows10 Korean Hangul edition

  2. New install : Windows10 Japanese edition
    → Results : same as Korean edition.

Summary of test results:

Windows 10 Engligh : Yes, fully displayed 
                     Korean : No
                    Japanese : No
Windows 11 Korean : No

I’ve heard Korean or Japanese (and Chinese maybe) characters are
double-byte, whereas English alphabet is of single-byte.
I think Microsoft applies different window-size to double-byte characters.

Hi @sohon23m, can you please try an experiment when time permits?

  • Create a new user on your machine with admin rights.
  • Log in as that user, and change the language to english (US)
  • Log out and log back in to the new account, and verify you are seeing everything in english
  • Log out of the new account and and log in with your normal account.
  • Navigate to the installed location of the QA40x.exe (not the link!)
  • Shift+right click on the QA40x.exe and select “run as different user” and enter the login credentials of the new account

How does the application look? Can you share a png of the add measurement dlg?

Hi Matt,
Yes I will test it and report the results.

Hi Matt’
Test results.

  1. Created a new user account.

  2. Logged in as new user, and changed the system language to English(US)
    Captured screen:

  3. Logged in as original account, and selected “run as differnt user”.
    (Program Files(x86)/QantAsylum/QA40x/QA40x.exe–>Shift+right click)

    Capture screen: same as before.

  4. For another test, I logged in with new user account (system language: English)
    and installed newly QA40x.exe_v0.9999.

    Captured screen: same as original account (system language :Korean)

Hi Matt,

I’ve tried running the above test again, step by step and slowly.
And I found, by chance, a button called “Administrative languages settings”.

Here is new process.

  1. Log in at new user account (system language: English)

    settings–>Language–> click “Administrative languages settings”

  2. select “Administrative” tab(default).
    click “Copy settings”–>“OK” buttons.

  3. We can find “Welcome screen” settings;
    Display language : 한국어 (it means Korean Language)
    Format : Korean(Korea)
    Location : Korea

3_1: Check the check box “Welcome screen and system account”. as following
screen shot.

3_2: As soon as the checkbox is checked, all the "Welcom screen settings
are changed to English.
3_3: click “OK” button.

  1. At the pop-uped dialog box, click “Restart now” button

  2. After restart, log in original account.(language : Korean)
    (Here, I uninstalled the existing QA40x.exe, and re-installed
    new QA402.exe_v0.9999, for clean set up.)

  3. Excute QA40x.exe(by clicking the shortcut icon, as usual).

    results : perfect pop-up window

Because I changed the “Welcome screen” settings, I checked if there were changes
to other programs and applications,but I found no significant changes yet.

I’ll try this solutions to Windows11 Korean Edition and Windows10 Japanes edition.
(It seems to take 2-3 days.)

Please check if this would be a common solution.

Did you notice if Windows installed a new font at some point? For a future release, we will add the ability to force a language from the command line for an experiment. Your study is extremely helpful, thanks!

Hi Matt,
Windows10 system added a English font pack as follows.

  1. After I created a new user and log in,

    • the “Windows display language” was Korean language (only one).
    • the “Preffered languages” was Korean (only one)
  2. I added Enlish(United States) at “Preffered Languages”–>click “add a language”.
    System installed automatically Enlish font pack,but there was no notice about the name of font pack.

  3. Then “Enlish(United States)” option appeared at “Windows display language” and I selected it.

(And after I restarted Windows10, I found out, at the “Preffered languages”,
the priority was automatically changed to Engligh first. )